package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a(?:.*?)(?:href="(?:(https?:\/\/)([\w-]{1,32}\.[\w-]{1,32})[^\s@]*)?")?>(.*)<\/a>`)
var str = `<a href="http://yandex.ru"></a>
<a href=""></a>
<a href="">asdasd</a>
<a href="" target="_blank">asdasd</a>
<a></a>
<a><p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}