const regex = /<a(?:.*?)(?:href="(?:(https?:\/\/)([\w-]{1,32}\.[\w-]{1,32})[^\s@]*)?")?>(.*)<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a(?:.*?)(?:href="(?:(https?:\\\/\\\/)([\\w-]{1,32}\\.[\\w-]{1,32})[^\\s@]*)?")?>(.*)<\\\/a>', 'g')
const str = `<a href="http://yandex.ru"></a>
<a href=""></a>
<a href="">asdasd</a>
<a href="" target="_blank">asdasd</a>
<a></a>
<a><p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}