import Foundation
let pattern = #"<a(?:.*?)(?:href="(?:(https?:\/\/)([\w-]{1,32}\.[\w-]{1,32})[^\s@]*)?")?>(.*)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a href="http://yandex.ru"></a>
<a href=""></a>
<a href="">asdasd</a>
<a href="" target="_blank">asdasd</a>
<a></a>
<a><p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)