package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)cite:[^@][A-Za-z0-9_-]+|\[\[cite:[^@][A-Za-z0-9_-]+\]\]`)
var str = `I want to recognize these as org-ref links
[[cite:schuett-2018-schnet]]
cite:schuett-2018-schnet
but not
[cite:@schuett-2018-schnet]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}