import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "cite:[^@][A-Za-z0-9_-]+|\\[\\[cite:[^@][A-Za-z0-9_-]+\\]\\]";
final String string = "I want to recognize these as org-ref links \n\n"
+ "[[cite:schuett-2018-schnet]]\n"
+ " cite:schuett-2018-schnet\n\n"
+ "but not\n\n"
+ " [cite:@schuett-2018-schnet]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}