$re = '/(?<=S—CLOAD NO )\w+/m';
$str = 'S—CLOAD NO A12345-AAB ARGRG
S—CLOAD NO A127921-SM001 RWGRW
S—CLOAD NO A133—AAB NOFAFNER';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);