package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\b[A-Za-z0-9]{3,4}\s[A-Za-z0-9]{3}\b)`)
var str = `STATION ROAD, KINGS HEATH, BIRMINGHAM B14 7TB
BOW STREET, LONDON, WC2E 7AH
STATION ROAD, LONDON SE20 7BQ
Station road London SE20 7BQ UK=
Station road London SE20 7BQ UK
Station Road Penge SE20 7BQ London
Station Road SE20 7BQ London
`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}