using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[[^]]+\]\]|\w+";
string input = @"[[File:Euclid flowchart 1.png|vignette|[[Flowchart]] of an algorithm ([[Euclid's algorithm]]).]] blablablabla this "" is ' ' (yes) not a link. This is a link [[Al-Andalus|andalou]] and this [[Babylone|Babyloniens]] is a link with a pipe in it.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}