$re = '/^\b\d?(?:[A-Z]\d)*[A-Z]?$/m';
$str = 'D1B2C4Q3
DDA1Q3
D$1A2B
1
11
A
AA
1A2B
1AA2
B2C33
B2C3D4
B2C3D4EE
B2C3D4E5G
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);