const regex = /^\+?(?:1(\s|-|\.)?)?(\d{3}\1?\d{3}\1?\d{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?(?:1(\\s|-|\\.)?)?(\\d{3}\\1?\\d{3}\\1?\\d{4})$', 'gm')
const str = `1 555 222 5545
1-555-222-5562
.555-222-5562
5552226585
+1.888.558.5585
1 5552223334`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}