# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\W?1.*(\d{3}).*(\d{3}).*(\d{4})$/1($1) $2-$3/gm;t' <<< "19999999999
+19999999999
1-999-999-9999
1-(999) 999-9999
238934265981239"