re = /^\W?1.*(\d{3}).*(\d{3}).*(\d{4})$/m
str = '19999999999
+19999999999
1-999-999-9999
1-(999) 999-9999
238934265981239'
subst = '1($1) $2-$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result