const regex = /\(([^\)]*)\) started playing (.*?\b)(?: - ([^\.]+))?\.$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(([^\\)]*)\\) started playing (.*?\\b)(?: - ([^\\.]+))?\\.$', 'gm')
const str = `hyper_d (Galaxy S9) started playing King of the Hill - Episode 419.
hyper_d (Galaxy S9) started playing Mr. & Mrs. Smith.
hyper_d (Galaxy S9) started playing Kick-Ass.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}