package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:TCP|UDP)\/\d+(?:-\d+)?(?:,(?:TCP|UDP)\/\d+(?:-\d+)?)*$`)
var str = `TCP/53,UDP/53,TCP/10-20,UDP/20-30
TCP/53UDP53,TCP/10-20UDP20-30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}