#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[I,V,X]{1,3}."
Local $sString = "IX. století" & @CRLF & _
"Matematika pro VII. třídu" & @CRLF & _
"Game of Thrones III" & @CRLF & _
"Karel IV." & @CRLF & _
"papež Benedict V." & @CRLF & _
"Bělá je X. část statutárního města Děčín." & @CRLF & _
"III. patro" & @CRLF & _
"II. stupeň povodňové aktivity"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")