$re = '/[I,V,X]{1,3}./m';
$str = 'IX. století
Matematika pro VII. třídu
Game of Thrones III
Karel IV.
papež Benedict V.
Bělá je X. část statutárního města Děčín.
III. patro
II. stupeň povodňové aktivity';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);