const regex = /^[a-zA-Z\u0600-\u06FF,-\s\d][\s\d\a-zA-Z\u0600-\u06FF,-]*$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z\\u0600-\\u06FF,-\\s\\d][\\s\\d\\a-zA-Z\\u0600-\\u06FF,-]*$', 'i')
const str = `RegExp that accept English and عربي plsu numbers like 2 وكذلك ٢`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}