re = /^[a-zA-Z\u0600-\u06FF,-\s\d][\s\d\a-zA-Z\u0600-\u06FF,-]*$/i
str = 'RegExp that accept English and عربي plsu numbers like 2 وكذلك ٢'
# Print the match result
str.match(re) do |match|
puts match.to_s
end