# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"sender\":.*?\"id\":\"(?<senderId>\d+)\""
test_str = ("\"{\"object\":\"page\",\"entry\":[{\"id\":\"111111111111111\",\"messaging\":[{\"sender\":{\"id\":\"49783635606516156\", \"options\":\"TETX_ARRAY\"},\"recipient\":{\"id\":\"111111111111111\"},\"message\":{\"mid\":\"m_secret\",\"text\":\"\\/start\"}}]}]}\";\n\n"
"\"{\"object\":\"page\",\"entry\":[{\"id\":\"111111111111111\",\"messaging\":[{\"sender\":{\"options\":\"TETX_ARRAY\", \"id\":\"49783635606516156\"},\"recipient\":{\"id\":\"111111111111111\"},\"message\":{\"mid\":\"m_secret\",\"text\":\"\\/start\"}}]}]}\";")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.