using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^;\r\n])([""]+)([^;\r\n])";
string substitution = @"$1$3";
string input = @"""A"";1;200;345;""Apotheker ""Blue tongue"";""Apeldoorn"";12;""ABCD12""
""B"";2;232;312;""Cafe ""Blue Oyster"";""Rotterdam"";33;""DCBA21""""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}