# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^;\r\n])([\"]+)([^;\r\n])"
test_str = ("\"A\"\";1;200;345;\"Apotheker \"\"Blue tongue\"\";\"Apeldoorn\";12;\"ABCD12\"\"\n"
"\"\"B\";2;232;312;\"Cafe \"Blue Oyster\";\"Rotterdam\";33;\"DCBA21\"\"\"\"")
subst = "$1$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.