// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"([^;\r\n])(["]+)([^;\r\n])"#).unwrap();
let string = "\"A\"\";1;200;345;\"Apotheker \"\"Blue tongue\"\";\"Apeldoorn\";12;\"ABCD12\"\"
\"\"B\";2;232;312;\"Cafe \"Blue Oyster\";\"Rotterdam\";33;\"DCBA21\"\"\"\"";
let substitution = "$1$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}