package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*[i|I]'?[m|M](.+)$`)
var str = `Whatevwer, i'm ok`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}