import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<inner>(?<![\\p{L}'])(?:\\p{L}+')+\\p{L}+(?![\\p{L}']))|\n"
+ "(?<began>(?<!\\p{L})(?:'\\p{L}+)+(?![\\p{L}']))|\n"
+ "(?<ended>(?<![\\p{L}'])(?:\\p{L}+')+(?!\\p{L}))|\n"
+ "(?<outer>(?<!\\p{L})'\\p{L}+'(?!\\p{L}))";
final String string = "'Twas---Wha'? Wouldn'tcha'? 'Twas, or 'twasn't, 'tis what's 'tween dawn 'n' dusk 'n stuff. Cookin'? 'Sams' place, 'yo'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}