#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?<!\.)\d{3}(?:\.\d{2})?\b(?!\.)"
Local $sString = "X306" & @CRLF & _
"50.17080" & @CRLF & _
"8.69507," & @CRLF & _
"50.178075," & @CRLF & _
"50.050512" & @CRLF & _
"117.234" & @CRLF & _
"49.172" & @CRLF & _
"129" & @CRLF & _
"105.123432" & @CRLF & _
"107.23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")