$re = '/\b(?<!\.)\d{3}(?:\.\d{2})?\b(?!\.)/';
$str = 'X306
50.17080
8.69507,
50.178075,
50.050512
117.234
49.172
129
105.123432
107.23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);