package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:if(\W+)(\d+)-)?(\d+\.?\d*)([%$])`)
var str = `2.3%
3.5%
if>=100000-1.6%,if<100000-100$
if>=100000-1.6%,if<100000-100$
500$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}