// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:if(\W+)(\d+)-)?(\d+\.?\d*)([%$])").unwrap();
let string = "2.3%
3.5%
if>=100000-1.6%,if<100000-100$
if>=100000-1.6%,if<100000-100$
500$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}