// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r#"(?m)\b(?i)Create(?-i)\b\s*(?:\b.+\s*)*\(\s*"\s*.+\s+(?:\w+\s*)+""#).unwrap();
  let string = "creATe fsfsfsf (\"mustHaveThisWord mustHaveThisWordOrMoreWordsAfter third\" Number Not Null)";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}