use strict;
my $str = '37.248884°N, 76.505324°W';
my $regex = qr/.*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";