re = /^[a-zA-Z]([a-zA-Z0-9-]*[a-zA-Z0-9])?(\.[a-zA-Z]([a-zA-Z0-9-]*[a-zA-Z0-9])?)*$/m
str = 'www.google.com
www-ftp--mail.google-feast.com-and-enjoy
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end