Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?<device>{[^^]*})\^(?<topic>{[^^]*})\^(?<payload>.*)$
/
gm
Input 1
1
New
{"r":"presenter_id","s":"client0_id","id":"3961825726-request"}^{"requestId":"3961825726","route":"/basic/handshake/join","role":"request"}^{"playerName":"Marta"}