import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<device>\\{[^^]*\\})\\^(?<topic>\\{[^^]*\\})\\^(?<payload>.*)$";
final String string = "{\"r\":\"presenter_id\",\"s\":\"client0_id\",\"id\":\"3961825726-request\"}^{\"requestId\":\"3961825726\",\"route\":\"/basic/handshake/join\",\"role\":\"request\"}^{\"playerName\":\"Marta\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}