const regex = /^(?<device>{[^^]*})\^(?<topic>{[^^]*})\^(?<payload>.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<device>{[^^]*})\\^(?<topic>{[^^]*})\\^(?<payload>.*)$', 'gm')
const str = `{"r":"presenter_id","s":"client0_id","id":"3961825726-request"}^{"requestId":"3961825726","route":"/basic/handshake/join","role":"request"}^{"playerName":"Marta"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}