// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<device>{[^^]*})\^(?<topic>{[^^]*})\^(?<payload>.*)$").unwrap();
let string = "{\"r\":\"presenter_id\",\"s\":\"client0_id\",\"id\":\"3961825726-request\"}^{\"requestId\":\"3961825726\",\"route\":\"/basic/handshake/join\",\"role\":\"request\"}^{\"playerName\":\"Marta\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}