using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(~[0-9.% ]+.* )?price increase(.*~[0-9.%]+)?";
string input = @"After price increase of ~0.1% vs others in Year 2020:
After ~6% - 7% price increase vs others in Year 2019:
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}