using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/(?:www\.)?(.+)";
string substitution = @"https://www.${1}";
string input = @"http://domain.com
http://www.domain.com
https://domain.com
https://www.domain.com";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}