package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([[0-9]+[ \+\-\(\)[0-9]*]*]*)`)
var str = `This is some text with +1 (234) 222-9898 a phone number in it and a random number 12. Also here is a +44 0800 655 5059 UK number
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}