# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+[a-z])([0-9]+)([a-z].+)/$1x$3/gm;t' <<< "aaaaaaa0aaa
bbbbbbb0bbbbbb
cccccc 2.0"