import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\d+(?:\\.\\d+){3}$)0+\\.(?:0+\\.)*";
final String string = "0.0.4.1\n"
+ "7.51.4.1\n"
+ "0.1.4.1\n"
+ "001\n"
+ "0.1\n"
+ "0.0.0.0";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}