use strict;
my $str = '0.0.4.1
7.51.4.1
0.1.4.1
001
0.1
0.0.0.0';
my $regex = qr/^(?=\d+(?:\.\d+){3}$)0+\.(?:0+\.)*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";