re = /^(?=\d+(?:\.\d+){3}$)0+\.(?:0+\.)*/m
str = '0.0.4.1
7.51.4.1
0.1.4.1
001
0.1
0.0.0.0'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result