# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<iframe.*src=\".*embed\\/(.*?)\".*?<\\/iframe>/[YT]\1[\/YT]/g;t' <<< "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/ED96RtfF22E\" frameborder=\"0 \"allowfullscreen> </iframe>"