package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<iframe.*src=\".*embed\/(.*?)\".*?<\/iframe>`)
var str = `<iframe width="560" height="315" src="https://www.youtube.com/embed/ED96RtfF22E" frameborder="0 "allowfullscreen> </iframe>`
var substitution = "[YT]\1[/YT]"
fmt.Println(re.ReplaceAllString(str, substitution))
}