const regex = /<iframe.*src=\".*embed\/(.*?)\".*?<\/iframe>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<iframe.*src=\\".*embed\\\/(.*?)\\".*?<\\\/iframe>', 'g')
const str = `<iframe width="560" height="315" src="https://www.youtube.com/embed/ED96RtfF22E" frameborder="0 "allowfullscreen> </iframe>`;
const subst = `[YT]\1[/YT]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);