// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<iframe.*src=\".*embed\/(.*?)\".*?<\/iframe>"#).unwrap();
let string = "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/ED96RtfF22E\" frameborder=\"0 \"allowfullscreen> </iframe>";
let substitution = "[YT]\\1[/YT]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}