import Foundation
let pattern = #"^(?:\+1)?\(?(\d{3})\)?[\s\.-]?(\d{3})[\.-]?(\d{4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
6305673452
(630)567-3452
(630) 567-3452
630.567.3452
630-567-3452
+16305673452
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"($1)$2-$3 +1$1$2$3 $1-$2-$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)