package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div id="PageTitle">.+?<\/div>`)
var str = `<div id="PageTitle"> Page title as a string </div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}