# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(location \\/api.*?proxy_pass\s*)([^ ;]+)/$1http:\/\/localhost:1234/gms;t' <<< "server {
listen 80;
server_name localhost;
location /api {
rewrite /api/(.*) /$1 break;
proxy_pass https://host.name:1337;
proxy_redirect off;
proxy_set_header Host $host;
}
location / {
root /usr/share/nginx/html;
index index.html index.htm;
}
}"