import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(location \\/api.*?proxy_pass\\s*)([^ ;]+)";
final String string = "server {\n"
+ " listen 80;\n"
+ " server_name localhost;\n\n"
+ " location /api {\n"
+ " rewrite /api/(.*) /$1 break;\n"
+ " proxy_pass https://host.name:1337;\n"
+ " proxy_redirect off;\n"
+ " proxy_set_header Host $host;\n"
+ " }\n"
+ " location / {\n"
+ " root /usr/share/nginx/html;\n"
+ " index index.html index.htm;\n"
+ " }\n"
+ "}";
final String subst = "$1http://localhost:1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}